指南 /

安装

/

系统要求

系统要求

Piwigo requires a web hosting to run. For a photo gallery solution with all included (installation, hosting, backups), or if you simply want to try Piwigo with no installation, you may consider opening a free trial account on Piwigo.com.

Minimum Requirements

  • A web server like Nginx or Apache
  • MySQL 5.6+ or MariaDB 10.1+. MySQL 5.0 works but is no longer maintained.
  • PHP 7.3+. Piwigo can run with PHP 5.3+ but these end-of-life versions are no longer maintained and may expose your site to security vulnerabilities. See officially PHP supported versions.
  • A graphic library: ImageMagick is recommended for its performances and image quality but GD, often bundled with PHP, can also do the job.
  • an FTP client software will be required to upload the files (netinstall or full package): Piwigo team recommends FileZilla as FTP client software, because it is free as Piwigo is, and compatible with Windows, Mac and Linux.
  • Enough disk space for your pictures: in addition to the photos you upload, Piwigo will store the "multiple sizes" in a cache directory of your server.

Optional Requirements

  • exiftool is required for plugin Write Metadata or any other plugin dealing with EXIF/IPTC metadata
  • ffmpeg is required for plugin VideoJS to create video poster
  • pdftoppm will be recommended to generate poster from PDF files (instead of ImageMagick)

还有其他问题吗?

你可以在社区里提问,也可以在文档中寻找答案